Vilka enheter är kompatibla med Jaybird-appen?

Jaybird-appen är kompatibel med enheter som kör iOS 11 och senare och Android 6.0 och senare.

Behöver du mer support?

Om du har några frågor som inte besvaras här kanske vårt forum kan hjälpa till.
Missa aldrig något!

Registrera dig och få exklusiva erbjudanden och uppdateringar.

Följ oss

#poweryourpassion